Сканер штрих кода через rdp

Сканер штрих кода через rdp

Настроить сканер штрих кода на локальном компьютере не составляет особого труда. Может, конечно, вопрос о том как настроить сканер штрих кодов в терминальной сессии больше беспокоит начинающих админов, или малоопытных, а может и в правду есть какие то заморочки при которых эта связка способна парить голову, и отьедать много времени, пока наступит тот момент, в котором все будет работать. Во время поиска решений на разных форумах и сайтах, было замечено что основную трудность вызывает настройка 1C версии 7.7. Здесь же приведен пример настройки для Серверной версии 1С 8.2 конфигурации Управление Торговлей (версия 10.2).

Торговля широким ассортиментом продукции, требует автоматизации контроля. Сегодня автоматизация бухгалтерии организации с использованием систем штрихкодирования уже не дикость и не дорогое решение, а доступное, и вполне разумно его внедрение и использование. Плюсов контроля товародвижения с помощью штрих кодирования много. Эта система уменьшает обьем работы ручного труда.

Столкнувшись с необходимостью данной настройки сканера штрих кода в терминале, пришлось покопаться в интернете, где по крупицам была собрана полезная информация. На основе, которой и было все настроено. Теперь в понятной форме и с цветными картинками все будет изложено ниже. При настройка сканера, приходится рисковать настройками безопасноти соединения 1С с сервером.

Вообще все просто, главное это правильная последовательность действий. Вся суть в том что MSTSC служба доступа к терминальному сервису, позволяет использование локальных устройств в терминальной сессии. То есть, если мы работаем в терминале за компьютером к которому подключен принтер или сканер, эти подключенные устройства также используются.

Итак чтобы настроить сканер шк для работы на удаленном компьютере, понадобятся дистрибутивы MetroPOS и ScanOPOS. Уатанавливаем набор библиотек для поддержки санеров 1С:Саканер штрихкода.

Первым делом подключаем сканер штрихкода к компьютеру. Что бы избежать всяких казусов с настройками сканера, желательно взять инструкцию от него, найти таблицу штрих кодов, и используя штрих код «Defaullt settings» сделать ему сброс настроек.

Устанавливаем утилиту MetroPOS, которая дает возможность проверить правильно ли настроен наш сканер, щагрузить с него файл конфигурации и загрузить его обратно. А также проверить сканер на считывание штрих кода.

После установки нужно сделать четыре действия, запускаем программу

Выбираем нашу модель сканера (в данном случае 5140)

Выбираем COM порт к которому подключен сканер

Тыкаем Upload (1),

Дожидаемся специфичного сигнала сканера

Тыкаем в значек Download (2)

Потом нажимаем на Terminal Window (3), открывается дочернее окно

Читайте также:  Advocam fd8 profi gps blue

Сканируем какой нибудь штрих код, он должен появится в этом окошке.

Если код появился все в порядке, можно идти дальше. Если нет… Ищем причину.

Следующий шаг, создание и настройка RDP файла, для подключения к терминальной сессии.

Полностью инструкцию приводить не будем, скажу только основное в данном этапе, это галочки для включения трансляции COM порта.

Это все мы проделали на локальной машине, к которой непосредственно и подключен сканер ШК. Теперь нам нужно войти в терминальную сессию, и проделать эти же действия на удаленном компьютере, начав с установки MetroPOS и ScanOPOS.

Как настроить сканер штрих кода в 1с 8.2 (8.1)

Заходим Меню Сервис — Торговое оборудование — Подключение и настройка торгового оборудования

Переходим на вкладку Сканеры штрихкода

нажимаем "Добавить новый" и выбираем обработку обслуживания: 1С сканер штрихкода

Задаем название конфигурации сканера и нажимаем ОК

нажимаем Проверка

проверяем верно ли выставлены параметры порта к которому подключен сканер, нажимаем тест устройства, если все настроено верно, то выйдет окошко "тест пройден"

Перенаправления портов при помощи службы терминала Windows

Службы терминалов Windows Server 2003/2008 иемют поддержку автоматического перенаправления портов COM и LPT. Включается перенаправление в галочкой "последовательные порты" в панели "Устройства" закладки "Локальные ресурсы" (в настройках ярлыка параметров удаленного рабочего стола». Процесс перенаправления портов сам по себе считается операцией не безопасной, о чем собственно службы терминалов нас и предупреждает сообщением. В момент создания сеанса RDP происходит перенаправление портов "один в один", то есть порту COM1 компьютера клиента сопоставляется порт COM1 сеанса службы терминала, соответственно порту COM2 — COM2, LPT1 — LPT1 и так далее

Для того чтобы проыерить, происходит ли перенаправление портов в удаленном сеансе терминала, надо в командной строке ввести команду: "change port /query".

Если командная строка выдаст такое сообщение – значит перенаправление работает.

COM1 = DeviceRdpDrPort;COM1:7 sclientCOM1
COM2 = DeviceRdpDrPort;COM2:7 sclientCOM2
LPT1 = DeviceRdpDrPort;LPT1:7 sclientLPT1

А так выглядят — неперенаправленные порты (тоже самое мы увидим, если наберем в командной строке на локальном компьютере: "change port /query":
COM1 = DeviceSerial0

В случае если перенаправление по каким то причинам не происходит, посмотрите в настройках Windows Server 2003/2008 установки службы терминалов:

Включены ли перенаправляемые порты на самом сервере:

еще один из "народных рецептов" это переименовывание ком порта, к которому подключен сканер штрих кодов. По умолчанию всегда используется первый системный COM порт (у современных компьюетров только один порт выведен на заднюю панель, и то не всегда), так вот, рекомендуют его переименовать в любой другой отличный от первого. делается это через диспетчер устройств.

Читайте также:  Время репликации контроллеров домена

Теги материала: терминал, сканер, штрихкод, настройка сканера, сканер шк, сканер в терминале, сканер и RDP, как настроить, торговля

Для начала все сканеры должны висеть на разных com портах. Поменять номер порта можно в диспетчере устройств, в разделе Порты (COM и LPT) необходимо выбрать нужный порт и вызвать его свойства, там перейти во вкладку "Параметры порта" и по кнопке "Дополнительно" вызвать дополнительные параметры, где можно сменить номер порта. И при подключении к удаленному рабочему столу необходимо убедится что галочка перекидывать порты установлена. На сервере проверить перекинулся ли порт можно командой "change port".

На сервере не забываем установить компоненту "1С: Сканер штрихкода", ну и добавление сканера в самой программме 1С: Управлении торговлей описывать не буду, в этом сложности никакой нет. Но напишу тока, что сканеров будет несколько привязанных к данному компьютеру, т.е. в конфигурации УТ оборудование привязано к конкретному ПК. Если у вас только один сканер то он без проблем должен работать, если порт прокинут конечно))). Но вот если их два и больше могут возникать проблемы с которыми я столкнулся.Проблема была в том что работал только один сканер остальные не работали.

Решение проблемы: После продолжительных танцов с бубнами))), пошел юзать отладчик, и обнаружил интересный код, который находится в обработке "ТОСервер". В нем есть функция "ПодключитьОборудование()", которая пытается подключить в цикле сканеры забитые в базе и привязанные к данному компу.Так вот кусок кода в цикле:

Результат = Обработка.Подключить(Объект);
Если ЗначениеЗаполнено(Результат) Тогда
Возврат Результат;
КонецЕсли;

прикол в том что, при попытке подключить первое обородование в цикле, если она неудачная, то функция возвращала ошибку подключения, даже не пытаясь подключить остальные сканеры из списка.

Вот как я подправил данный фрагмент кода:

//Если ЗначениеЗаполнено(Результат) Тогда
// Возврат Результат;
//КонецЕсли;
Если Результат = Перечисления.ТООшибкиОбщие.ОшибкаПриПодключении Тогда
Продолжить;
КонецЕсли;

После чего все прекрасно заработало, и все были счастливы, особенно я после стольких танцов. Просто даже в голову изначально не приходило, что все из за кода конфигурации. Буду очень рад если кому то данная статья поможет.

8plus.ru — это отчеты и обработки 1С только версии 8 и только для типовых конфигураций!

  • Основное
  • Файлы
  • Комментарии
  • Версия для печати
Читайте также:  Шлюз установленный по умолчанию недоступен windows 10

ОС: Win server 2003, 2008 х64

Была задача: удаленные филиалы подключить по rdp к одному серверу под управление win 2008 и сканеры штрих-кодов тоже, но они никак не хотели работать. То есть если работал один, остальные не работали. Ну и хотелось поделится опытом решения проблемы, вдруг кому-то тоже поможет. 🙂
Напишу сразу это решение проблемы для конкретного релиза УТ 10.3.3.3, на остальных не проверял может уже исправили в последующих.

Для начала все сканеры должны висеть на разных com портах. Поменять номер порта можно в диспетчере устройств, в разделе Порты (COM и LPT) необходимо выбрать нужный порт и вызвать его свойства, там перейти во вкладку «Параметры порта» и по кнопке «Дополнительно» вызвать дополнительные параметры, где можно сменить номер порта. И при подключении к удаленному рабочему столу необходимо убедится что галочка перекидывать порты установлена. На сервере проверить перекинулся ли порт можно командой «change port».

На сервере не забываем установить компоненту «1С: Сканер штрихкода», ну и добавление сканера в самой программме 1C: Управлении торговлей описывать не буду, в этом сложности никакой нет. Но напишу тока, что сканеров будет несколько привязанных к данному компьютеру, т.е. в конфигурации УТ оборудование привязано к конкретному ПК. Если у вас только один сканер то он без проблем должен работать, если порт прокинут конечно))). Но вот если их два и больше могут возникать проблемы с которыми я столкнулся.Проблема была в том что работал только один сканер остальные не работали.

Решение проблемы: После продолжительных поисков, через отладчик, обнаружил интересный код, который находится в обработке «ТОСервер». В нем есть функция «ПодключитьОборудование()», которая пытается подключить в цикле сканеры забитые в базе и привязанные к данному компьютеру:

Результат = Обработка.Подключить(Объект);
Если ЗначениеЗаполнено(Результат) Тогда
Возврат Результат;
КонецЕсли;

суть в том что, при попытке подключить первое обородование в цикле, если она неудачная, то функция возвращала ошибку подключения, даже не пытаясь подключить остальные сканеры из списка.

Вот как надо поправить фрагмент кода:

//Если ЗначениеЗаполнено(Результат) Тогда
// Возврат Результат;
//КонецЕсли;
Если Результат = Перечисления.ТООшибкиОбщие.ОшибкаПриПодключении Тогда
Продолжить;
КонецЕсли;

После чего все прекрасно заработало, и все были счастливы, особенно я после долгих поисков. Просто даже в голову изначально не приходило, что все из за кода конфигурации. Буду очень рад если кому то данная статья поможет.

Источник: Infostart (с согласия автора davlen)

Ссылка на основную публикацию
Сервер не поддерживает символы не ascii
Многие из нас пользуются замечательным FTP сервером FileZilla Server. Думаю, не я один столкнулся с проблемой некорректного отображения русских букв...
Ресивер пионер vsx 528
5.1 канальный AV ресивер Pioneer VSX-528 с 6x HDMI, AirPlay, DLNA, MHL, сквозным сигналом Ultra HD 4K и Интернет-радио vTuner....
Ресивер для нтв плюс какой лучше
Телекомпания НТВ‑ПЛЮС гарантирует получение качественных услуг, а также обеспечение корректного доступа к каналам и дополнительным сервисам Телекомпании, только при условии...
Сервера для обновления nod32 бесплатно
Отличие полной версии от триальной Полные (не триальные) антивирусные базы и программные компоненты Eset Antivirus и Eset Smart Security! Отличия...
Adblock detector